Cómo extraer el nombre del mes (o del día) a partir de una fecha

¿Necesitas sacar el nombre del mes de una fecha? ¿O tal vez deseas obtener el nombre del día de la semana? Este artículo explica cómo hacer eso (y algunas cosas más) de manera sencilla.


La forma más básica

La forma más conocida de extraer el mes de una fecha es utilizar la función MES. Esta función nos da como resultado un número entre 1 y 12, que corresponde al mes de la fecha indicada. Su sintaxis es la siguiente:

=MES(fecha)


Entre paréntesis debemos indicar una fecha, de alguna de las siguientes maneras:

  • Escribiéndola directamente, entre comillas. Por ejemplo: =MES("20/04/2017")
  • Haciendo referencia a una celda que contenga una fecha. Por ejemplo: =MES(B3)
  • Ingresando una fórmula que devuelva una fecha. Por ejemplo: =MES(HOY())
  • Ingresando el número de serie de una fecha. Por ejemplo: =MES(42845). (Este es el modo menos usado. Excel, en su manejo interno, utiliza una serie de números, desde el 1 al 2958465, para representar las fechas entre el 01/01/1900 y el 31/12/999 inclusive. Aquí puedes leer más sobre la forma en que Excel maneja las fechas.)

 

Extraer el día, el mes o el año de una fecha son cosas muy parecidas

Así como para sacar el mes de una fecha puedes usar la función MES, puedes obtener el día o el año de una fecha con las funciones DIA y AÑO, respectivamente.

Su sintaxis es idéntica a la de la función MES. Para extraer el día de una fecha es: =DIA(fecha). Para extraer el año de una fecha: =AÑO(fecha)

Todas estas funciones devuelven su resultado en forma de número.



Obtener el nombre del mes

Para poder extraer el nombre de un mes a partir de una fecha podemos usar la función TEXTO. Su sintaxis es la siguiente:

=TEXTO(valor; formato


Como primer argumento de la función TEXTO debemos especificar la fecha que contiene el mes buscado. (Podemos hacer esto de cualquiera de las maneras que se mencionan más arriba para indicar la fecha en la función MES.)

El segundo argumento es una cadena de texto preestablecida que indica a Excel cómo debe mostrar el resultado.

En el caso de que queramos que Excel devuelva el nombre completo del mes, la cadena de texto que debemos ingresar como segundo argumento es: "mmmm", comillas incluidas.

=TEXTO("20/04/2017";"mmmm") retorna abril

 

Si ingresamos la cadena "mmm", Excel devolverá el nombre del mes abreviado, es decir, solo sus tres primeras letras. (ene para enero, feb para febrero, etc.)

=TEXTO("20/04/2017";"mmm") retorna abr



Obtener el nombre del día de la semana

Para obtener el nombre del día de la semana, debemos usar la función TEXTO de forma idéntica a la ya explicada, a excepción del segundo argumento.

El segundo argumento en este caso debe ser "dddd" (para que Excel nos devuelva el nombre del día completo) o "ddd" (para que lo muestre abreviado).

=TEXTO("20/04/2017";"dddd") retorna jueves

=TEXTO("20/04/2017";"ddd") retorna ju o jue (dependiendo de la versión de Excel)

 

Para extraer el nombre del mes de la fecha de hoy puedes usar la fórmula =TEXTO(HOY();"mmmm").

Para extraer el nombre del día de la semana de la fecha de hoy puedes usar la fórmula =TEXTO(HOY();"dddd")



Con minúscula, mayúscula o mayúscula inicial

Un detalle importante es que la función TEXTO devuelve tanto los nombres de los meses como de los días siempre en minúscula. Para que los muestre en mayúsculas debemos introducir la función TEXTO dentro de la función MAYUSC, del siguiente modo:

=MAYUSC(TEXTO(fecha; formato))

Para que los nombres sean retornados solo con la primera letra mayúscula y las demás en minúscula, debemos introducir la función TEXTO dentro de la función NOMPROPIO:

=NOMPROPIO(TEXTO(fecha; formato))

=MAYUSC(TEXTO("15/07/2017";"mmmm")) retorna JULIO

=MAYUSC(TEXTO("15/07/2017";"ddd")) retorna o SÁB

=NOMPROPIO(TEXTO("15/07/2017";"mmmm")) retorna Julio

=NOMPROPIO(TEXTO("15/07/2017";"ddd")) retorna o Sáb


¿Te pareció práctica esta información? Si es así, te invito a suscribirte a nuestro boletín gratuito, para mantenerte al tanto de los artículos y noticias más relevantes que se publiquen en el blog.

2 comentarios en «Cómo extraer el nombre del mes (o del día) a partir de una fecha»

    • Hola, Luis.
      El artículo se centra más bien en obtener el nombre del mes o del día de la semana a partir de una fecha.
      De todos modos gracias por la sugerencia.
      Espero revisar todos los artículos pronto y tomaré en cuenta tu comentario.
      ¡Saludos!

      Responder

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.