Cómo extraer fácilmente el nombre del mes (o del día) desde una fecha

A veces nos vemos ante la necesidad de tener que extraer el mes de una fecha. Esto lo podemos hacer fácilmente con la función MES. El inconveniente es que esta función nos devuelve solo el número del mes y lo que necesitemos frecuentemente es su nombre. ¿Qué función nos devuelve el nombre del mes (o el nombre de un día de la semana) de forma sencilla?

Extraer el nombre del mes en Excel

Primera opción: Obtener el número del mes

Como dije antes, la función MES nos retorna un número entre 1 y 12 que corresponde al mes de la fecha especificada. La sintaxis es:

MES(fecha)

Como argumento debemos indicar una fecha, de alguna de las siguientes maneras:

Escribiéndola directamente, entre comillas. Por ejemplo: =MES(“20/04/2017”)
Haciendo referencia a una celda que contenga una fecha. Por ejemplo: =MES(B3)
Ingresando una fórmula que devuelva una fecha. Por ejemplo: =MES(HOY())
Ingresando el número de serie de una fecha. Por ejemplo: =MES(42845). (Excel, en su manejo interno, utiliza una serie de números, desde el 1 al 2958465, para representar las fechas entre el 01/01/1900 y el 31/12/999 inclusive. Aquí puedes leer más sobre la forma en que Excel maneja las fechas)

Extraer el número del mes

 

Segunda opción: Obtener el nombre del mes

Podemos usar la función TEXTO para que Excel nos devuelva el nombre de un mes.

La función TEXTO convierte valores numéricos en formato texto y permite personalizarlo con una serie de opciones. Dentro de estas opciones de personalización las relacionadas con la fecha y la hora son las más interesantes. (Debemos recordar que, en su manejo interno, para Excel las fechas no son otra cosa que una serie de valores numéricos.)

En el caso que nos ocupa, la sintaxis de la función TEXTO es la siguiente:

TEXTO(fecha; formato)

Como primer argumento debemos indicar la fecha que contiene el mes buscado, con alguna de las formas que detallamos para la función MES. La forma de indicar la fecha en las funciones MES y TEXTO es idéntica.

El segundo argumento es una cadena de texto preestablecida que indica a Excel cómo debe mostrar el resultado.

En el caso de que queramos que Excel devuelva el nombre completo del mes, la cadena de texto que debemos ingresar como segundo argumento es: “mmmm”, comillas incluidas.

=TEXTO(“20/04/2017″;”mmmm”) retorna abril

Extraer el nombre del mes entero

Si ingresamos la cadena “mmm”, Excel devolverá el nombre abreviado, es decir, solo las tres primeras letras del nombre. (ene para enero, feb para febrero, etc.)

=TEXTO(“20/04/2017″;”mmm”) retorna abr

Extraer el nombre del mes abreviado

 

Obtener el nombre del día de la semana

La función para extraer el día de una fecha es DIA. Su sintaxis es similar a la de la función MES:

DIA(fecha)

Para obtener el nombre del día de la semana, debemos usar la función TEXTO de forma idéntica a la ya explicada, a excepción del segundo argumento.

El segundo argumento en este caso debe ser “dddd” (para que Excel nos devuelva el nombre del día completo) o “ddd” (para que lo muestre abreviado).

=TEXTO(“20/04/2017″;”dddd”) retorna jueves

=TEXTO(“20/04/2017″;”ddd”) retorna ju o jue (dependiendo de la versión de Excel)

Extraer el nombre del día

 

En minúscula, mayúscula y mayúscula inicial

Un detalle importante es que la función TEXTO devuelve tanto los nombres de los meses como de los días siempre en minúscula. Para que los muestre en mayúsculas debemos introducir la función TEXTO dentro de la función MAYUSC, del siguiente modo:

MAYUSC(TEXTO(fecha; formato))

Para que los nombres sean retornados solo con la primera letra mayúscula y las demás en minúscula, debemos introducir la función TEXTO dentro de la función NOMPROPIO:

NOMPROPIO(TEXTO(fecha; formato))

Extraer texto de una fecha

=MAYUSC(TEXTO(“15/07/2017″;”mmmm”)) retorna JULIO

=MAYUSC(TEXTO(“15/07/2017″;”ddd”)) retorna SÁ o SÁB

=NOMPROPIO(TEXTO(“15/07/2017″;”mmmm”)) retorna Julio

=NOMPROPIO(TEXTO(“15/07/2017″;”ddd”)) retorna Sá o Sáb

 

¿Te pareció práctica esta información? Si es así, te invito a suscribirte a nuestro boletín gratuito, para mantenerte al tanto de los artículos y noticias más relevantes que se publiquen en el blog.

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.