¡Excel no calcula, no resuelve las fórmulas! ¿Qué hago?

Escribes una fórmula en una celda y presionas ENTER... Sin embargo, en vez de aparecer el resultado que esperas, permanece la fórmula tal cual la escribiste, como un texto… Presionas ENTER de nuevo, pero no ocurre nada. ¿Se "rompió" Excel o qué está pasando?


Delimitando el problema

Qué ingreses una fórmula en una celda y no obtengas el resultado esperado puede deberse a infinidad de causas. Por eso, antes de que sigas leyendo, me gustaría delimitar bien la situación sobre la que estamos hablando en este artículo.

Como se indica en el ejemplo del encabezado, nos referiremos a los casos en que Excel no muestra el resultado de la fórmula ingresada, sino que la celda muestra la fórmula tal cual la escribiste, como un texto.

Si en lugar de lo anterior, la celda muestra un mensaje de error, como #¿NOMBRE? o #¡VALOR!, te recomiendo revisar el artículo Significado de los mensajes de error en las celdas de Excel.



¿Es por el formato?

Muy frecuentemente, la causa del problema es el formato aplicado a la celda.

Si ingresas una fórmula en una celda que tiene aplicado el formato Texto, Excel considerará la fórmula como un texto y no intentará resolverla.

La solución para esto, en principio, es sencilla. Basta con:

  1. Aplicar el formato General a la celda (ficha Inicio, grupo Número, opción General en la lista desplegable).
  2. Hacer doble clic sobre la celda.
  3. Presionar la tecla ENTER.

Los pasos 2 y 3 son necesarios porque la celda no se actualizará con solo cambiarle el formato, hay que forzar su actualización.

Otra opción, en lugar de hacer doble clic sobre la celda, sería hacer clic en la Barra de fórmulas y presionar ENTER.

 



Corregir varias fórmulas a la vez

Si tenías que corregir la fórmula de una sola celda ya deberías haber solucionado el problema.

Pero es posible que tengas que modificar mucho más que una o dos fórmulas. En este caso, entrar celda por celda para reingresar la fórmula no es una opción viable. ¿Qué puedes hacer?

Hay una forma sencilla de hacer que Excel "refresque" todas las fórmulas, por medio de la herramienta Reemplazar.

Realmente, no necesitamos reemplazar ninguna parte de la fórmula. Pero podríamos "simular" un cambio, pidiéndole a Excel que reemplace un signo de igual por otro signo de igual. Esto obligará a Excel a actualizar todas las celdas que tengan una signo de igual, sin alterar en nada su contenido.

Los pasos a seguir son los siguientes:

  1. Presiona el atajo CTRL+L.
  2. En la ventana que se abrirá, escribe un signo de igual en la casilla Buscar y otro signo de igual en la casilla Reemplazar con.
  3. Presiona el botón Reeemplazar todos.



“¡Muy interesante, pero mi problema sigue!”

Sí, puede ser que tu problema no se haya solucionado con las recomendaciones anteriores. Incluso puede que la situación no se limite solo a un grupo de celdas, sino que todas las fórmulas de tu hoja se muestren como texto. Hasta fórmulas que hasta ayer funcionaban correctamente.

¡Calma! Es muy probable que sin querer hayas presionado CTRL+`, un atajo de teclado que activa el modo Mostrar fórmulas en Excel.

Si este es el caso, para que el modo Mostrar fórmulas se desactive, bastará con que vuelvas a presionar el mismo atajo (CTRL+`, es decir, presionar la tecla CTRL y, sin soltarla, el acento grave).

También puedes desactivar el modo Mostrar fórmulas en la ficha Fórmulas, dentro del grupo Auditoría de fórmulas. (Mira la imagen siguiente para más guía.)

Aunque esta funcionalidad quizás te parezca una broma "macabra" de Excel, tiene su razón de ser. Es muy útil para para identificar de un vistazo las celdas que contienen fórmulas y no tener que andar saltando de celda en celda cada vez que necesites revisarlas.

Al establecer el modo Mostrar fórmulas, Excel muestra todas las fórmulas de la hoja en lugar de sus resultados.



Una tercera situación

¡Todavía hay más! A veces puede ser que no tengas problemas al crear una fórmula, pero sí al arrastrarla.

Es decir, escribes la fórmula sin problemas y da el resultado correcto, pero cuando la arrastras a través de otras filas o columnas la fórmula no se adapta al contexto y siempre muestra el resultado de la fórmula original.

También puede ocurrirte que modifiques el valor de alguna celda esperando que las fórmulas que utilizan ese valor se actualicen, pero que no suceda nada. Como si las fórmulas se hubieran desconectado de las celdas de las que dependen y ya no respondieran a los cambios efectuados.

Si algo de lo anterior te sucede, muy probablemente se deba a que Excel ha modificado su modo de cálculo, pasando del Automático al Manual.

Afortunadamente, la solución es supersencilla:

Basta con hacer clic en la ficha Fórmulas, hacer clic en el botón Opciones para el cálculo y seleccionar el modo Automático.

Con eso, los problemas antes descritos deberían haber quedado resueltos.

¿Por qué se cambia a veces el modo de cálculo?

El modo de cálculo Automático es el predeterminado y lo más probable es que nunca hayas tenido intenciones de cambiarlo. Pero es posible que hayas abierto el libro de un tercero, guardado en el modo de cálculo Manual y que esta configuración haya afectado todos los libros que abriste después.



Cómo determina Excel el modo de cálculo a usar

  • Cuando abres un libro, la aplicación entera adopta el modo de cálculo con el que ese libro se guardó por última vez. Eso significa que todos los libros que abras posteriormente en esa sesión utilizarán el mismo modo de cálculo que el primero que abriste.
  • Al cambiar el modo de cálculo de un libro, lo cambias también para todos los demás libros abiertos.
  • Todas las hojas de un libro emplean el mismo modo de cálculo.
  • Si cambias el modo de cálculo en un libro y lo guardas, se guardará con ese modo de cálculo.

¿Para qué sirve el cálculo Manual?

El modo de cálculo Automático actualiza los resultados de las fórmulas de todo el libro ante cualquier cambio producido en las celdas de origen. Normalmente este proceso tarda una fracción de segundo. Pero en libros extraordinariamente grandes, cada recálculo puede llevar varios segundos e incluso minutos.

Para impedir estas demoras, Excel ofrece la posibilidad de cambiar el modo de cálculo a Manual. De esta forma, el usuario puede efectuar todas las modificaciones que desee sin ver interrumpido continuamente su trabajo y efectuar los cálculos solo cuando sea necesario, por medio de presionar la tecla F9.

Si deseas profundizar en el tema del rendimiento de Excel al manejar grandes volúmenes de datos, te recomiendo el siguiente artículo de Microsoft: Rendimiento de Excel: mejorar el rendimiento del cálculo.



Conclusiones

En Excel, a veces, ocurren cosas que nos desorientan un poco, pero podemos ver estos "despistes" como oportunidades para aprender. ¿Te ha sacado canas verdes algún problema similar a los que se plantean aquí? ¿Cómo lo resolviste? ¿Tienes actualmente algún problema con Excel que no puedes resolver?


Si esta información te pareció útil te invito a suscribirte a nuestro boletín gratuito, para mantenerte al tanto de los artículos y noticias más relevantes que se publiquen en el blog.

101 comentarios en «¡Excel no calcula, no resuelve las fórmulas! ¿Qué hago?»

  1. Excelente aporte. Había visto todas las soluciones en otras páginas menos lo de reemplazar.
    Me ayudaron muchísimo.

    ¡Bendiciones masivas!!!

    Responder
    • ¡Hola, Héctor!
      Me alegro de haber aportado algo que te haya sido útil.
      ¡Muchas gracias por comentarlo! Es un aliciente para seguir adelante.
      Saludos.

      Responder
  2. ¡Hola, amigo! A una compañera de mi escuela le sucede un problema. Y es que la fórmula/función no da resultados si se pone texto. Te pongo un ejemplo equis:

    =SI(A1=B2, "Hola", "Adiós")

    La única manera en que da resultados es solamente poniendo referencia a celdas. Ejemplo:

    =SI(A1=B2, C3, D4)

    Yo por más que trato de buscar una solución, no la encuentro. Al inicio pensé que le sucedía lo mismo que a mí, cuando empezaba Excel, que era poner unas comillas erróneas, ya que antes yo ponía estas ¨ ¨ y después me di cuenta que eran estas " ". Pero no, probé incluso hasta con comillas que ni siquiera sabía que existían y sigue igual. No sé si tu puedas ayudarme. Ella tiene Excel 2016.

    Responder
    • Hola, Jonathan. ¿Cómo estás?
      Sí, la verdad que es raro.
      Sinceramente, no me doy cuenta qué puede ser lo que está pasando.

      Trataré de averiguar un poco más y si encuentro algo te lo comparto.
      Si encuentras la solución por tu lado, avísame.
      ¡Saludos!

      Responder
  3. LO DE REEMPLAZAR EL "=" CON IGUAL SOLUCIONÓ UN PROBLEMA QUE TENÍA CON EXCEL DESDE HACE TIEMPO. NO SABES CUANTO TIEMPO AHORRA. ¡MUCHAS GRACIAS!!!

    Responder
    • Hola, Alejandra. ¿Cómo estás?
      Con tan pocos datos es muy difícil determinar el problema.
      ¿Podría ser una diferencia de redondeo?

      Responder
  4. Hola, tengo un problema con una fórmula sumamente sencilla. Quiero restar un valor de otro valor, mi fórmula está correcta pero en la celda donde se supone debe poner el resultado pone solo un guion, no pone el resultado. ¿Qué puedo hacer? ¡Gracias!

    Responder
    • Hola, Lucía.
      Sin ver el archivo es muy difícil de saber qué es lo que está pasando exactamente.
      Pero se me ocurre que podría deberse al formato aplicado a la celda.

      El formato de Contabilidad muestra un guion en lugar del cero. De modo que si la resta te diera cero, este formato lo mostraría como un guion.
      Es lo único que se me ocurre que puede estar pasando de acuerdo a lo que dices.

      Para quitar el formato de número de la celda, tendrías que seleccionarla y, en la ficha Inicio, en el grupo Número, cambiar el formato de la lista desplegable a "General".
      Ojalá te sirva.
      Saludos.

      Responder
      • Gracias, ya lo hice pero sigue haciendo lo mismo. Veo que si tiene formato de contabilidad el archivo, lo cambié pero sigue igual. De hecho, en celdas que están en blanco me hace lo mismo. Es un libro de trabajo del cual se van copiando las hojas, quizá el error venga de más atrás. Voy a hacer esa sola hoja en un libro nuevo y luego la copiaré al libro en el que estoy trabajando a ver si se soluciona. Muchísimas gracias por tu pronta respuesta.

        Responder
        • Hola, Lucía. Sí, me parece buena la idea de probar con un libro nuevo y comparar con el que tienes. Eso te puede ayudar. ¡Suerte! Gracias por tu comentario.

          Responder
  5. Yo recién empiezo en mi escuela a ver Excel a fondo. El problema que tengo es que al escribir en mi teclado comandos como el de ALT+SHIFT+0 en mi hoja de Excel no pasa nada. ¿Hay que activar alguna opción?

    Responder
    • Hola, Saray.
      Supongo con que el atajo ALT+SHIFT+0 estás tratando de insertar una autosuma.
      En ese caso, el problema creo que debe estar relacionado con el tipo de teclado que usas.
      Porque el atajo en realidad es ALT+=.
      Generalmente, ALT+SHIFT+0 es equivalente a ALT+=, porque, en los teclados en español, el signo "=" está encima del cero.
      Pero si ALT+SHIFT+0 no funciona, creo que la mejor solución sería buscar el signo de igual (=) en tu teclado y usar ALT+=.
      Espero haberte ayudado.
      ¡Saludos!

      Responder
  6. Hola, gracias por la información, pero en mi caso no he podido solucionar el problema. Al ejecutar las fórmulas me aparece que he indicado muy pocos argumentos en la función, pero está bien escrita. ¿Qué puedo hacer?

    Responder
    • Hola, Miguel.
      Es prácticamente imposible saber qué puede estar pasando sin ver la fórmula.
      Lo primero que miraría sería la sintaxis. Por ejemplo, si los separadores de los argumentos son los correctos, si los números no tienen formato, si los textos están entre comillas, si la cantidad y posición de los paréntesis es la correcta, etc.
      Espero te sirva.
      ¡Saludos!

      Responder
  7. Hola, mi fórmula se construye desde VBA con la intrucción: Range(Cells(LineaImp, 13), Cells(LineaImp, 13)).Formula = "=SI.ERROR(BUSCARV(L2," & NombreHoja & "!" & Vect(j) & Ultcelda & ",3,0),0)", obteniendo en mi hoja la formula correcta =SI.ERROR(BUSCARV(L2;'2018'!C3:E7;2;0);0), pero que me muestra como #¿NOMBRE?. La edito, le doy Enter y la resuelve. No es problema de formato. Si reemplazo el = por otro = también lo resuelve, pero yo necesito que la fórmula se resuelva al ejecutar la macro. Desde ya te agradezco por lo que haces.

    Responder
    • Hola, Daniel.
      La propiedad Formula solo admite los nombres de la funciones en inglés. Por lo que deberías usar IFERROR y VLOOKUP en lugar de SI.ERROR y BUSCARV al escribir el código. Estos nombres se traducirán al español automáticamente en la celda.

      Otra opción es usar la propiedad FormulaLocal, en lugar de Formula. De ese modo el intérprete de VBA sabrá que debe usar los nombres locales de las funciones.

      ¡Saudos!

      Responder
  8. Descargo un archivo con datos, estos datos contienen fechas con horas. Inserto una columna para aplicar la función HORA y que me calcule la cantidad de horas que hay en ese casilla, pero me devuelve #¡VALOR! Lo extraño del caso es que en otra computadora sí funciona la fórmula.
    En el enlace te adjunto una captura de pantalla:
    https://wetransfer.agenciadigital.cr/Fxn2Mfnu
    Mi compañero, al que si le funciona la fórmula, dice que debe ser una cuestión del formato de descarga de la máquina, pero trabajo con Windows 10 igual que él.
    Es una fórmula simple, lo raro es que si pongo en otra hoja una fecha y la calculo, sí lo permite.

    Responder
    • Hola, Bryan.
      Sí, como se indica en la propia imagen que me compartiste, el problema es el ".0" que tiene cada dato al final.

      Puedes eliminar esa parte de forma sencilla siguiendo estos pasos:
      1) Selecciona todos los datos de la columna Asignado.
      2) Presiona CTRL+L.
      3) En la ventana que se abrirá, escribe ".0" en la casilla Buscar. La casilla Reemplazar con déjala vacía.
      4) Presiona el botón Aceptar.

      Creo que con eso el problema se tendría que corregir.
      Saludos.

      Responder
  9. Buenas. Tengo una celda que me da un resultado nulo en el gráfico, sin embargo cuando le aplico la opción Mostrar fórmulas, aparece la celda correctamente citada y el valor correspondiente en la columna. ¿Cómo puedo solucionar esto?

    Responder
  10. ¡Hola!!
    ¿Me puede ayudar? Estoy trabajando con una base datos, cree una tabla donde están los datos. Quiero hacer una búsqueda pero no me muestra nada, no me dice error. Quiero hacer la búsqueda con el número de identidad, cuando lo ingreso no me arroja nada la búsqueda.
    Esta es la fórmula =SI.ERROR(BUSCARV(REGISTRO!$D$16;DATOS;2;FALSO);"")

    Responder
    • Hola, Mayra. ¿Cómo estás?

      Aparentemente la función BUSCARV no está encontrando el dato solicitado. Pero la fórmula no devuelve un valor de error porque la función SI.ERROR está haciendo que, ante un error, se muestre una celda vacía.
      Para verificar si hay un error en la búsqueda puedes probar la función BUSCARV por separado, sin SI.ERROR.
      Es decir: BUSCARV(REGISTRO!$D$16;DATOS;2;FALSO)

      Espero haberte servido de alguna ayuda.
      Saludos.

      Responder
  11. Hola, ¿cómo estás? Tengo el siguiente problema.

    Cuando hago el BUSCARV la función queda con N/A. Si abro la celda donde está la función y cierro con Enter, ahí sí hace la búsqueda. Pero si cambio el resultado que quiero buscar, vuelve a quedar N/A. Si repito el mismo proceso, la búsqueda sí la hace.

    Saludos.

    Responder
    • Hola, Matías.
      Sin ver la planilla es difícil saber lo que está pasando.
      Pero podría ser porque el valor buscado en la función está como número y el de la lista auxiliar está como texto o viceversa.
      Ambos valores deben ser números o textos para que la función BUSCARV funcione correctamente.
      Saludos.

      Responder
    • Hola Matias,

      A mí me sucede lo mismo con fechas, tengo que abrir la celda para que la función BUSCARV encuentre el valor. Y obviamente no puedo abrir todas las celdas en las que quiero que la función trabaje.

      Una solución rápida que he encontrado es crear una columna y usar la formula DATEVALUE en dicha columna desde la columna original con las fechas. Luego uso el BUSCARV en la nueva columna (aquella en la que he usado DATEVALUE) y BUSCARV funciona.

      Si alguien sabe por que sucede esto y conoce alguna otra solución me encantaría conocerla.

      Un saludo.

      Responder
      • Hola, Joaquín. ¿Cómo estás?
        La función DATEVALUE (FECHANUMERO, en español) convierte una fecha ingresada como texto en una fecha válida.

        Tu problema se debe a que BUSCARV no encuentra coincidencia entre el texto que indicas como primer argumento y las fechas de la matriz de búsqueda.
        Pero convirtiendo el dato buscado de texto a fecha se establece la coincidencia y BUSCARV devuelve el valor relacionado.

        Espero haberme explicado.
        Gracias por tu aporte.
        ¡Saludos!

        Responder
    • Hola, tal vez me puede ayudar. Intento ingresar formula =MMULT(X6,40/200) y me da error: HAY UN PROBLEMA CON ESTA FORMULA.
      ¿INTENTA INTRODUCIR UNA FORMULA?
      Probé cambiando la coma por el punto y tampoco y ya probé las 3 opciones que usted da aquí y tampoco.

      Responder
    • Hola, Jorge.
      El error podría darse por muchas causas dependiendo del contexto.
      Lamentablemente no te puedo ayudar con tan poca información.
      Lo siento.

      Responder
  12. Hola, buenas tardes.
    Mira, tengo un problema con la siguiente fórmula:
    =SI.ERROR(INDICE(SEPARADO[FACTURAS];COINCIDIR(0;CONTAR.SI($G$5:G5;SEPARADO[FACTURAS]);0));"")
    Me sale un error y no entiendo por qué, ya que en el libro donde lo vi funciona bien. La fórmula original aparece entre {}, pero cuando le doy doble clic se quitan solos. ¿Qué hago?

    Responder
    • Hola, Andrés.
      Por lo que me dices se trata de una fórmula matricial.
      Para que funcione, en lugar de ingresarla con ENTER, tienes que usar la combinación CTRL + SHIFT + ENTER.
      Espero te sirva.
      Saludos.

      Responder
  13. Hola, buenas. Tengo un problema, porque mi Excel no me permite estas fórmulas: =SI(B9=0,"Es igual a cero","Es otro número") y =SI(B9=1,"A",SI(B9=2,"B","C"). No entiendo porque en otras computadoras con Excel funciona y en la mía no. Necesito saber con prisa qué es lo que sucede. Estaré atenta a su respuesta.

    Responder
    • Hola, Denisse.
      No sabría decirte a ciencia cierta, porque tendría que ver el contexto en el que estás usando la fórmula.
      Pero lo primero que probaría es cambiar cada comas que separa los argumentos de la función SI por punto y coma.
      Por ejemplo: =SI(B9=0;"Es igual a cero";"Es otro numero")
      ¡Espero te sirva!!

      Responder
  14. Hola, ¿me puedes ayudar? Siempre que intento poner una fórmula en mi Excel me sale una ventana que dice: "Hay un problema con esta fórmula" "¿No intenta introducir esta formula?" y mi fórmula esta correcta, porque en otras laptops si funciona y no sé por qué en la mía no. Ya probé poniendo coma y punto y coma y nada. Necesito ayuda, por favor.

    Responder
    • Hola, Mayra.
      Lo primero que te hubiera dicho es cambiar el separador de argumentos de coma a punto y coma o viceversa.
      Lo que ya probaste.
      La verdad es que puede haber muchas variables que determinen que una fórmula de Excel no funcione.
      Si envías la fórmula podré ver qué elementos usa y tal vez pueda descubrir cuál puede estar causando el problema.
      ¡Saludos!

      Responder
  15. Tengo esta formula =SI($A41>$D$9;" ";SI(Y($C$1="PRIMER";$AB$1=1);BUSCARV($A41;NOTASQ1;C$110);SI(Y($C$1="PRIMER";$AB$1=2);BUSCARV($A41;NOTASQ1;C$111);SI(Y($C$1="PRIMER";$AB$1=3);BUSCARV($A41;NOTASQ1;C$112);SI(Y($C$1="SEGUNDO";$AB$1=1);BUSCARV($A41;NOTASQ2;C$110);SI(Y($C$1="SEGUNDO";$AB$1=2);BUSCARV($A41;NOTASQ2;C$111);SI(Y($C$1="SEGUNDO";$AB$1=3);BUSCARV($A41;NOTASQ2;C$112);SI($C$1="QUIMESTRE1";BUSCARV($A41;NOTASQ1;25);SI($C$1="QUIMESTRE2";BUSCARV($A41;NOTASQ2;25);SI($C$1="ANUAL";BUSCARV($A41;FINAL;C$116);SI($C$1="FINAL";BUSCARV($A41;FINAL;C$117);""))))))))))) que jala valores de una tabla... El problema es que las filas anteriores (la 40 hacia arriba) si muestran los valores, pero a partir de la 41, 42, 43, no muestra nada y vuelve a mostrar los valores de la 44 en adelante... Ahora, si en la formula cambio $A41 por $A40 sí me muestra el valor... ¿Cuál puede ser el error?... GRACIAS...

    Responder
    • Perdón, Iván. Pero es prácticamente imposible detectar el error que me indicas en una fórmula tan compleja y extensa y sin tener como contexto los datos que usa. Lo siento.
      ¡Saludos!

      Responder
  16. ¡Buenas tardes! Saludos! Desde Venezuela. Me alegra que brinden ayuda como esta. Mi problemita, ojalá me puedan ayudar, es este: Tengo esta fórmula matricial: =SUMA(SI(TEXTO($B$4:$B$57;"T")="E";SI(TEXTO($K$4:$K$57;"aaaa")="2021";SI(TEXTO($J$4:$J$57;"mmm")=N10;$G$4:$G$57)))), la cual suma según el mes y el año.
    Ella funciona perfectamente y me da los resultados esperados. El problema es que cuando abro el .xls en otra computadora, en cualquier versión de excel (2010, 2013 o 2016) todos los resultados de esta formula se van a cero. Intenté con el Shif+Ctrl+Enter en cada fórmula y nada. ¿Qué creen que pueda estar pasando? Gracias de antemano.

    Responder
    • Hola, Dennis.
      La verdad es que tendría que ver la fórmula en su contexto para entender por qué no funciona.

      Pero desde Excel 2007 en adelante puedes usar la función SUMAR.SI.CONJUNTO que te permite sumar los valores de un rango que cumplan diversas condiciones, de forma más simple.

      Este es un ejemplo del uso de SUMAR.SI.CONJUNTO que quizás te sirva o puedas adaptar a tus necesidades: =SUMAR.SI.CONJUNTO($G$4:$G$57;$B$4:$B$57;"E";$K$4:$K$57;2021;$J$4:$J$57;3)

      La sintaxis de esa función es la siguiente: =SUMAR.SI.CONJUNTO(Rango de suma; Rango del primer criterio; Primer criterio; Rango del segundo criterio; Segundo criterio; Rango del tercer criterio; Tercer criterio)

      Espero haberte sido de ayuda.
      ¡Saludos!

      Responder
    • Hola, Citlali.
      Al parecer el símbolo que usa tu sistema para separar los argumentos de las funciones es la coma.
      Si es así, hay un error en el punto y coma que antecede al segundo SI.
      Creo que cambiando ese punto y coma por una coma se solucionaría el problema.
      ¡Saludos!

      Responder
  17. Hola tengo una fórmula que me jala datos de las filas, por ejemplo, de la 1 a la 5, pero yo arrastre la formula hasta la fila 10 y a partir de la fila 5 o 6 hacia adelante me aparece el resultado en blanco. En las primeras filas si me aparece, ¿me podrían ayudar, por favor?
    Esta es la fórmula:
    =SI(I4>$C$3-1;"";BUSCARV(I4;DATAS!$A:$B;2;0))

    Responder
    • Hola, Enrique.
      Lamentablemente, sin poder ver la planilla no sé qué decirte.
      En principio, la fórmula está bien planteada.
      No hay errores de sintaxis. Tal vez el problema esté en la lógica o en los datos.
      Saludos.

      Responder
  18. Hola. Tengo un problema con mi Excel. Cualquier fórmula que inserto me arroja el error #¿NOMBRE?. Reviso las fórmulas y están bien.
    =BUSCARV(A13;'[Plano.xls]Plano por Departamento'!$A$1:$B$2300;2;0)
    No sé si es mi Excel que está funcionando mal. Gracias.

    Responder
    • Hola, Nadia.
      Pudiera ser que en tu versión de Excel la función BUSCARV se llame CONSULTAV.
      Prueba a cambiar un nombre por otro y ve si funciona.
      ¡Saludos!

      Responder
  19. Hola amigos, mi Excel no reconoce la siguiente función:
    =SI(A2=A1;"Repetido";"Ok")
    Lo raro es que sólo en mi computador no funciona, pruebo la fórmula en los Excel de otros PC y funciona.

    Al parecer tiene problemas con el signo "=".

    Saludos y gracias.

    Responder
    • Hola, Jaime.
      No creo que el problema sea el signo de igual.
      Podrías probar a cambiar los punto y comas por comas.
      Dependiendo de la configuración del sistema eso puede variar.
      Espero te sirva.
      Saludos.

      Responder
    • Hola, Sandra.
      Debe ser porque no estás reservando suficiente espacio para los datos.
      Deberías seleccionar un rango suficientemente grande como para mostrar todos los datos antes de hacer la fórmula.
      Primero selecciona el rango y luego, sin tocar más nada, escribe la fórmula. Ésta aparecerá en la celda activa.
      Por último, guarda la fórmula matricial, con CTRL+SHIFT+ENTER, y el rango seleccionado se llenará con los valores de la matriz resultante.
      Si haces una fórmula matricial en una celda, solo tienes lugar para ver el primer valor de la matriz.
      Espero haberme explicado.
      ¡Saludos!

      Responder
  20. Buenas, tengo un problema en Excel cuando intento introducir una fórmula: =D4&'', ''&C3 Me aparece error, dice HAY UN PROBLEMA CON ESTA FÓRMULA NO INTENTA INTRODUCIR UNA FORMULA, pero sí quiero introducir una fórmula y no la reconoce. Me alegraría que lo solucionaran. Gracias.

    Responder
    • Hola, Grethel Z.
      La sintaxis de la fórmula es correcta.
      ¿Será que estás usando un juego de comillas que Excel no reconoce?
      El mensaje que da Excel es muy genérico, no tiene por qué aplicar a tu caso y generalmente no lo hace.
      Saludos.

      Responder
  21. Buenas. Yo pongo una fórmula tal como =800*(1+0,003)^3 y me da error en la última parte, la de ^3. Dice que necesito una ' al inicio, pero lo que yo quiero es que me calcule esa fórmula. ¿Alguien me puede ayudar?

    Responder
    • Hola, Andrea.
      Sinceramente, no sé a qué puede deberse el problema.
      La ventana que te aparece explicando el error tiene un mensaje genérico, por lo que frecuentemente no da la solución.

      Lo único que se me ocurre que te podría estar generando un error es que en tu sistema el separador decimal no sea una coma sino un punto. En ese caso, en vez de 0,003 deberías escribir 0.003.
      En lo demás no veo ningún problema.
      ¡Saludos!

      Responder
  22. Buenas.
    Tengo una fórmula aplicada en toda la columna, enlanzándola con una tabla en otra hoja. La fórmula es la siguiente: =BUSCARV(A3;Mapping!$A$1:$B$237;2;0).
    En la fila en la que lo genero me mapea correctamente (arrastro o hago Copy+Paste solo de formulas al resto de filas) y se me arrastra correctamente en términos de formula. Es decir, en la celda inmediatamente inferior sería =BUSCARV(A4;Mapping!$A$1:$B$237;2;0), pero el resultado en todas es exactamente el mismo. He comprobado que metiéndome una a una y presionando Enter me da el resultado correcto, pero son 253.999 filas. Obviamente me va a llevar una eternidad.
    ¿Sabrías cómo se soluciona este problema?

    Responder