Clases Excel
Domingo, 04 Enero 2015 18:14

Cómo verificar que todas las celdas de un rango tengan idéntico contenido (de modo simple)

Valora este artículo
(1 Voto)

En Excel existe una función, denominada IGUAL, cuyo propósito es evaluar si dos celdas tienen el mismo contenido. Pero lo que aquí planteamos es la necesidad de evaluar el contenido de cualquier cantidad de celdas, incluso miles, con una sola fórmula. Obviamente, hay unas cuantas maneras de conseguirlo, pero una de ellas le gana a todas en simplicidad.

Chequear celdas iguales 1

 

La fórmula

Suponiendo que el rango a evaluar fuera A1:A20000, la siguiente fórmula devolvería VERDADERO si todas las celdas de ese rango tuvieran idéntico contenido. Como es lógico, bastaría con que una sola celda de ese rango tuviera un contenido diferente para que el resultado de la fórmula fuera FALSO.

=CONTAR.SI(A1:A20000;A1)=CONTARA(A1:A20000)

 

 

Explicación

Gran parte de la belleza de esta fórmula radica en su sencillez. Aquí va la explicación:

 

La fórmula general consiste en la comparación de dos fórmulas.

=CONTAR.SI(rango;contenido esperado)=CONTARA(rango)

 

El signo de igual de color rojo evalúa si las funciones CONTAR.SI y CONTARA devuelven el mismo resultado.

 

La función CONTAR.SI, devuelve el total de celdas que cumplen con una condición establecida. El rango donde se aplicará la función se debe introducir como primer argumento y el criterio de búsqueda, como el segundo.

 

La función CONTARA cuenta todas las celdas, dentro del rango indicado como argumento, que tengan algún contenido.

 

Veamos un ejemplo:

=CONTAR.SI(A1:A20000;A1)=CONTARA(A1:A20000)

 

Chequear celdas iguales 2

 

 

CONTAR.SI(A1:A20000;A1) devuelve la cantidad de celdas que, dentro del rango A1:A20000, son iguales a A1.

 

CONTARA(A1:A20000) cuenta todas las celdas del mismo rango (A1:A20000), sin importar su contenido, siempre y cuando no estén vacías.

 

De manera que si la cantidad de celdas que tienen el mismo contenido es igual al total de celdas con contenido, entonces todas tienen el mismo contenido. Resumiendo:

= Celdas con igual contenido = Cantidad total de celdas

 

La comparación de ambas funciones da un resultado lógico: VERDADERO o FALSO. Será VERDADERO si todas las celdas del rango evaluado tienen idéntico contenido.

 

 

Siempre hay un "pero"...

Sí, siempre hay un “pero”… La fórmula es muy limpia y elegante, pero tiene dos salvedades importantes:

 

Primera salvedad: La fórmula ignora las celdas vacías. Es decir, no considera una celda vacía como un valor diferente. Dependiendo de las circunstancias esto puede ser un defecto o una virtud. De todos modos hay que tenerlo en cuenta.

 

Una solución para que la fórmula tome en cuenta las celdas vacías es:

=CONTAR.SI(A1:A20000;A1)=CONTARA(A1:A20000)+CONTAR.BLANCO(A1:A20000)

 

En este caso, si el rango tuviera alguna celda vacía el resultado sería FALSO.

 

Segunda salvedad: La fórmula no hace distinción entre mayúsculas y minúsculas. Considera que “ENERO” es igual que “enero”. Igual que en ítem anterior, este comportamiento pudiera ser el deseado. De lo contrario, estaríamos ante un nuevo problema que resolver. Las formas de remediar esto son variadas, pero creo que todas se alejan de la simplicidad buscada y por eso no las incluimos en este artículo. ¿Se te ocurre alguna forma sencilla de solucionarlo?

 

Visto 3645 veces Modificado por última vez en Domingo, 20 Marzo 2016 03:01

Deja un comentario

Los campos imprescindibles están marcados con asterisco (*). Tu dirección de correo nunca será publicada.

2 comentarios

  • Enlace al Comentario Clases Excel Sábado, 17 Junio 2017 16:57 publicado por Clases Excel

    Hola, Juli.
    Podrías poner una fila con los resultados correctos y después aplicar formato condicional a las filas de los concursantes para que se marquen sus aciertos de verde.
    Aquí te dejo el enlace a un vídeo de Office que explica cómo aplicar el formato condicional.
    https://goo.gl/zDAhQ1
    Saludos

  • Enlace al Comentario Juli Sábado, 17 Junio 2017 07:01 publicado por Juli

    Hola, somos un grupo de 20 amigos que jugamos a la quiniela. Anotamos las conbinaciones en una hoja de Excel. Ejemplo en la columna A ponemos todos los nombres de los participantes y en las demás columnas en horizontal 14 signos más el pleno al 15. Me gustaría corregir los aciertos marcando las celdas correctas con un color verde y las celdas que el signo sea incorrecto dejar la en blanco de cada fila de los participante de una manera simple sin tener que hacerlo a mano que es un trabajo arduo y tedioso.

Suscríbete a nuestro Boletín gratuito

Recibe periódicamente en tu email los últimos artículos, trucos, tutoriales y otras novedades de Excel.


Tus datos son confidenciales, nunca serán compartidos con nadie.

 


Inicio    Contacto    Términos y condiciones    Mapa del sitio

Ir arriba

Desarrollado por www.espectradesign.com